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Administer your RoomWizards from one location
The RoomWizard Administrative Console (RWAC) allows the user
to administer all of the RoomWizards in your enterprise from one
location. It’s a PC-based application that enables the user to:
•• Find all the RoomWizards on your network. (Though all versions
of RoomWizards can be found, firmware version 4.1 or newer
is required on the RoomWizards to enable the full features of
the console).
•• Perform administrative operations on multiple RoomWizards
at the same time, such as:
- Select a master (already-configured RoomWizard)
		 and replicate its configuration on all other
		 selected RoomWizards with one operation.

•• Logically group your RoomWizards together. There are no limits
on number of groups or the number of RoomWizards in a group.
•• Get status information on all your RoomWizards, such as:
- See what units are currently offline/experiencing problems
- See CPU loading, disk usage and other information on
		 any selected RoomWizard.
•• View and capture log files from RoomWizards.

- Intelligently upgrade the firmware of and apply
		 patches to all selected RoomWizards (even if
		 starting from different initial firmware versions)
		 with one operation.

Notice Regarding Personally Identifiable Information
This tool may expose personally identifiable information located in your calendaring system with RoomWizard devices.
About This Manual
This manual describes how to use the RoomWizard Administrative Console (RWAC) to allow the user to monitor and configure RoomWizards.
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Installation
The RWAC needs to be installed on a Windows-compatible computer, running Windows XP or higher. System hardware requirements
are minimal: less than 50MB of disk space and 100MB of RAM. The RWAC uses .NET and, under some circumstances, the user may
need to provide .NET 4.0 installation. Simply run RWAdminSetup.exe on your PC to install the software.

Starting the RWAC
Application Password
To ensure the security of the Administrative Console, the password
to access the Administrative Console must be changed from the
default password of “roomwizard” after installation. The new
password must adhere to the standard RoomWizard complexity
requirements (8-64 charachters, at least one each capital, lowercase,
number, and special char).

Registration
As security and feature changes are rolling out very quickly in today’s
world, we at Steelcase feel it is imperative that we be able to quickly
inform our customers of updates as they become available. To that
end, each time the user starts RWAC it will now prompt the user to
enter contact information in our customer database. This will take the
form of a dialog as shown to the right and navigate to our registration
website in the browser area of the RWAC window. Once registered,
this dialog will no longer be shown when starting RWAC.

Updating RoomWizard Administrative Console
If a newer version of RWAC becomes available, version 1.5 will inform
users about changes made in the most recent version. If the user wants
these updated features, the user may choose to update by using the
“Download Now” button and can install the newest version.

Refreshing previously saved RoomWizard list
During start-up of the RWAC app, the existing RoomWizard list will
be read. Under most circumstances, the user will want to refresh the
current status of these RoomWizards. However, as this can take a long
time for large lists, sometimes the user may want to access individual
RoomWizards without bothering to update the entire list. To facilitate
this, RWAC will prompt the user with an option to skip the initial start-up
status refresh process. This will occur only if the list is longer than 20
RoomWizards. The dialog will be similar to the example shown here.
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The Console Window
Each time RWAdmin.exe is started, the user is prompted for a password. The default password is “roomwizard” and can be
changed in the Options dialog. Enter the password, and the console window will appear.

MENU BAR

PROPERTY VIEW

RWLIST VIEWS

OUTPUT VIEWS

STATUS BAR

There are five areas of the Administrative Console. These are the Menu Bar, RWList Views, Output Views, Property Views, and Status Bar.
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Screen Area

Purpose

Screen Area

Purpose

Menu Bar

Provides basic access to core setup features

Output Views

Shows the various output from the Administrative Console

File Menu
- Save lists of RoomWizards (and associated credentials)
- Restore lists of RoomWizards (and associated credentials)

Web Page view
- Displays one of three pages from the RoomWizard currently
selected. This can be configured via the View->Web Page
menu item.
- The Reservation page, the Home page or the Front Panel
of the RoomWizard can be displayed in this window.

View Menu
- Set the application options
- Set the default Web Page view home page
- Open User Guide

Output tab view
- Shows information on what the Administrative Console is
doing and any issues that may have occurred

Search Menu
- Search the network for all RoomWizards
- Search the network for new RoomWizards

Error tab view
- Shows only errors that have occurred during operations,
to quickly locate problem units

About
- Shows legal information on the software
RWList Views

Provides three ways to view the RoomWizards:

Property Views

Groups tab view
- Shows the alphabetized list of groups and group members
Status tab view
- Sorts RoomWizards by status. The RoomWizards with issue will be
brought to the top to make it easy to find problematic units.
Versions tab view
- Sorts the RoomWizards by firmware version. The RoomWizards
with the newest firmware will be brought to the top of the list. This
makes it easier to see which RoomWizards need updating.

Shows information about a specific, selected RoomWizard
Configuration tab view
- Contains information about the RoomWizard that can be edited
directly in the tab, such as the room capacity, time zone, NTP
server information, etc.
Properties tab view
- Contains static information about the RoomWizards network
connection, serial number, and installed firmware and patch version
Status tab view
- Contains static information pulled from the RoomWizard, such
as the CPU, memory and drive status

Right-clicking on a group or selected RoomWizard brings up a
right-click menu with all of the options available for administering
the RoomWizards.

Additionally, there is information about the status of the RoomWizard
Synchronization, which includes the name of the active connector as
well as error conditions and codes (only if applicable).
Status Bar

Shows the current count of RoomWizards known to the Administrative
Console, information on what the Administrative Console is currently
doing, a progress bar if an operation is being processed, and the
Administrative Console version number.
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Configuration of the Administrative Console
On the first-time use of the Administrative Console, the main options need to be set, and the RoomWizard List needs to be set up.
To configure the main options, select View->Options to bring up the options dialog for the Administrative Console.
Font Settings
The font and the font size used in the application may be selected here.
SSH Command Settings
The Administrative Console will open a telnet session and log you
in automatically via the menus. Enter the path to your favorite telnet
client and the default timeout used for the telnet client. The default
command timeout is 15 minutes.
Broadcast Settings
The Administrative Console uses a broadcast to find RoomWizards.
You can customize the search time and refresh times here.

Email Server Settings
The Administrative Console will send an email to the specified
account when there are problems with a RoomWizard. Use the
controls here to set up email access for the console.
FTP Server Settings
The Administrative Console normally accesses firmware images
and upgrade instructions through a fixed HTTP site, but in the event
that site is not available, a backup option to look for this information
via an FTP site is provided. The location and credentials for this
backup site can be entered here.
Application Password
To maintain security of the Administrative Console, the password
to access the application can be changed here.

Setup of RoomWizard Lists
Once the options have been set, the RoomWizard List needs to be configured.
Automatic List Setup
If running RW20 with firmware 4.1 or newer, or RW10 with firmware
3.5.1.2 update, you can automatically search your network for all
RoomWizards via the Search->Search for All RoomWizards menu.
The Administrative Console will prompt for the subnet to search for
RoomWizards. The RoomWizard List will be automatically populated
with all the RoomWizards under a “Default” group.

Manual List Setup
To add a new RoomWizard to the list, or to add a RoomWizard that is
not new enough to respond properly to RWAC, right-click on any group
name in the Tree View List, and select List Maintenance->Add Unit. Fill
out the dialog box that comes up, press OK, and the RoomWizard will
be added to the selected group.

Note that the “Default” group name cannot be changed, and all
RoomWizards found in a search are automatically added to the
“Default” group.
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Once the RoomWizards are in the Administrative Console, you can
begin administering them.
All operations are selected and initiated from the property tab or status
tab by selecting the RoomWizards to operate on and right-clicking.
Eight menu items are available via the right-click menu:
•• Access
•• Certificates
•• Configure Multiple (Replicate)
•• Firmware
•• List Maintenance
•• Logfiles
•• Set as “Master” Device

Note: You must run Firmware 4.1 or later with RW20s, and Firmware 3.5.2
with RW10s to unlock all the features of the Administrative Console, including
searching and property retrieval. However, you can update firmware on
units with older firmware directly from the Administrative Console.
Note: FTP or SFTP, and secure telnet, are required for full functionality
of the Administrative Console.

•• Set Root Password

Access

Certificates

The Access menu allows you to do the following on the selected
RoomWizard(s)

The Certificates menu allows you to install new custom certificates into
your RoomWizard.

•• Refresh the Configuration, Properties, and Status View tabs.

•• "Add Certificate" prompts you for the alias name and the
certificate itself to load into the RoomWizard.

•• Refresh the operational status of the list entry.
•• Start your web browser on the RoomWizards home page.
•• Start your telnet client on the RoomWizard. Putty is an excellent
free SSH client that operates well with the Administrative Console
and RoomWizard.
•• Sync the RoomWizard's clock to your PC’s clock.
•• Set the RoomWizard to sync its clock via NTP.
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Configure Multiple (Replicate)
The Configure Multiple menu provides access to dialogs which will allow
complex configuration for the selected RoomWizards. The configuration
sets that are accessible in this way are listed below. More in-depth
discussion of the associated dialogs can be found in the appendices.

Two additional options are intended to be used in conjunction with “Set
as Master Device” below and allow you to use that master RoomWizard
as a template that configuration values are harvested from and then
replicated out to all selected RoomWizards.

•• Configure 802.1x (Appendix 2)

•• Push Configuration reads the configuration of the master device,
and duplicates it out to every selected RoomWizard. Note that
network configuration and specific room configuration, such as
facilities and room names, are not replicated, so RoomWizards
preserve the unique information.

•• Configure ID Lookup feature (Appendix 3)
•• Configure sending WD Logs via FTP/SFTP (Appendix 4)
•• Configure SNMP (Appendix 5)
•• Customize Front Panel Display (Appendix 6)
•• Configure Connector Synchronization (Appendix 7)

•• Push Partial Configuration pushes the NTP server address,
the admin password, and new certificate information (if provided)
to all selected RoomWizards. If a field is left blank in the dialog,
that field is not replicated to other units. No master is required
for partial configurations.

Firmware
The Firmware menu allows you to upgrade the firmware on the
selected RoomWizards.
Note that the Administrative Tool requires the firmware to be in
cpio.tar.gz format.
•• “Reboot Unit” instructs the RoomWizards to reboot.
•• “Rebuild” instructs the RoomWizard to restore its firmware. This is
the same as reinstalling the last full firmware update on the unit
and this should be used only when units are exhibiting issues that
aren’t related to the configuration.

“Upgrade Firmware” upgrades the firmware via one of three methods:
Automatic

Via FTP

•• Select the desired resulting version (target version) from the
dropdown list. There may be a delimiter in the list “— Optional”
which separates the required or recommended versions (above
the delimiter) from those that are customer specific and/or
optional to install.

•• Enter the FTP path to the firmware file and FTP credentials to
log into the FTP server that contains the firmware. A sample
FTP path is ftp://ftp.steelcase.com/firmwarefile.cpio.tar.gz.

•• Clicking the “Check Server for Latest Update” button will cause
the console to ask the FTP for an updated list of available versions
to choose from.
•• An option is provided to “Enter password(s) to reveal Custom
Release(s),” which allows the user to enter passwords associated
with releases not normally offered in the dropdown list. These
passwords would only be available through special communication
with Steelcase. More than one password can be specified and should
be entered with a space in between. Passwords are case sensitive.
•• When you click “OK” the console will evaluate each RoomWizard
individually and group them logically by current version number.
The console will then step each group toward the target version.
All rebooting and required intermediate upgrade steps will be
handled automatically by the console until all RoomWizards are
brought up to the target version.

Note: this is not a working path but only an example.
•• Enter the RoomWizard FTPs to the site directly to download
and install the update.
Via Local File
•• Enter the path to the firmware file, the user as “root,” and the
root password.
•• The Administrative Console will “FTP” into the RoomWizard(s)
and upload the firmware. Subsequently, the RoomWizard will
install the upgrade.
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List Maintenance
These menu items allow for customization of the lists of RoomWizards.
•• Add Group: Adds a new high-level group to the list
•• Add SubGroup: Adds a new subgroup to the selected group
•• Add Unit: Adds a new RoomWizard to the group
•• Delete: Removes the selected group or RoomWizard from the list
•• Resolve Duplicate Unit: Helps locate and merge any condition
where the same RoomWizard is listed in multiple locations in the
RoomWizard tree list.

Note: Drag and drop RoomWizards and groups to rearrange the lists
as required.
Note: The “Default” group is fixed and cannot be renamed or removed.

LogFiles
The LogFiles menu allows you to both download all the log files from the
selected units and view individual logs directly from units.
•• “Download All Logs” will collect all the log files on the selected units
and save them locally. These log files can be provided to Steelcase
Technical Support when issues arise.
The rest of the menu items allow you to directly view in a window
the following log files:
- Admin log
- Concurrent log
- EndUser log
- Epiphany log
- Firmware Patches log
- Front Panel log
- Jettystart log
- LocalHost log
- Message log
- Upgrade log

Set as Master Device
“Set as Master Device” makes the currently selected RoomWizard
the master RoomWizard. Its configuration can be pushed out to other
RoomWizards via the replicate menu.

Set Root Password
This option will allow you to change the root password on all selected
RoomWizards. The default root password should be changed to reduce
security risks, as the default value is widely known and publicized.
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Configure a new RoomWizard installation
1. Install the RoomWizards and power them up.
2. Search for RoomWizards via the Search->Search for All
RoomWizards menu item.
3. Select View->Administrative Page on the menu.
4. All the RoomWizards will appear in the RWList property tab.
5. Select one RoomWizard.
6. Individually configure this RoomWizard either using the RWAC
Configuration View tab or the RoomWizard Web Interface Admin
Pages.
7. Right-click on the configured RoomWizard and select “Set as
Master Device”.
8. Select the remaining RoomWizards.
9. Right click and select Replicate->Push Configuration.
All the units are now configured, and unique configuration can be
added individually.

Configure Individual RoomWizard using
Configuration tab view
When the Configuration tab view is selected, clicking in an individual
entry will allow you to make changes directly to the value for the
currently selected individual RoomWizard. For most of these entries, the
value can be changed directly. However, there are some that indicate a
logical group of related configuration values and will actually bring up a
dialog to allow setting of any of the values for this logical group. These
logical groups can be found at the bottom of the list as shown.

When one of these logical groups is selected, the user will be presented
with a “Yes, No, Adjust” option that will then bring up a further dialog
that allows for adjustment of the values in the logical group. These
dialogs are discussed in depth in Appendices 2-7.

There is one additional logical group customization option that
appears slightly different from the others. It is “Connector Sync Mode”
and it has the options of “Classic” (stand-alone), “Sync” (synchronized
with an external connector), or “Adjust,” which again will bring up a
further dialog that allows for adjustment of the values in the logical
group. This dialog is discussed in depth in Appendix 7.
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Interpreting List Colors and Icons
The list of RoomWizards in the left side panel may have colors
associated with both the foreground and background for each entry.
Foreground Text Coloration
•• Black: This RoomWizard is running with no issues.
•• Blue: This RoomWizard needs to be rebooted.
•• Red: This RoomWizard is not responding on the network.
•• Yellow: This RoomWizard currently has an error condition or warning.
•• Grey: This RoomWizard is running a Firmware version that is below 4.1.
Background Coloration
•• White: Indicates that the console considers this RoomWizard
to have the currently recommended firmware/patch. This can
also occur if the console cannot make FTP contact with the
public version site and so has no way to know what the current
recommended version is.
•• Yellow: Indicates that the console considers this RoomWizard to
have a minor version difference from the currently recommended
firmware/patch (only differs in 3rd or 4th digit of version).
•• Red: Indicates that the console considers this RoomWizard to
have a major version difference from the currently recommended
firmware/patch (differs in 1st or 2nd digit of version).
•• Green: Indicates that the console considers this RoomWizard
to have a version or patch that is in advance of the currently
recommended firmware/patch. (This can occur when a customerspecific patch is installed and has a higher version than the currently
recommended firmware/patch.)
Icons related to Default “root” Password still in use
••

Indicates a RoomWizard with default appearance.

••

Indicates a RoomWizard that has had some customization of the
front panel appearance. This can take the form of an added badge
(logo) image or a change in the color scheme for the display.

••

An exclamation point added to the icon indicates that a
RoomWizard is found to still be set to use the factory default “root”
password. It is strongly advised that this password be changed once
the RoomWizard is established on your network. The new password
must meet the criteria of being at least 6 characters in length and
having at least one each capital letter, lowercase letter, and number.

••

Indicates that the RoomWizard data has not been successfully
initialized so no indication of “root” password or customization status
can be displayed.
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Best Practices
Upgrade Firmware
Upgrading firmware requires sending a new firmware file to every unit
selected, which can be 150MB in size, or to every RoomWizard in an
organization.
To optimize firmware upgrades and minimize the amount of time each
upgrade takes, we recommend dividing the RoomWizards into groups,
such as a group per building or per facility. This both reduces the load
on the network and reduces the possibility of failed downloads through
network retries.
With smaller groups being updated, the time required to perform
updates on the group is reduced, and the overall load is broken up
for both the IT administrator and the network.
Note: If FTP/SFTP is disabled on the RoomWizard units, firmware
upgrades will not work. FTP/SFTP is required for firmware upgrades
and patches.
Grouping RoomWizards by type
We recommend grouping similar RoomWizards together, e.g.,
keeping RW10s in one group and RW20s in another group. This will
allow upgrading firmware on all RW20s and all RW10s with only two
operations (one for each group), without having to first validate which
units were updated and which need different firmware loads.

RoomWizard lists
The File Menu option to save or reload different groupings of your
RoomWizards can be used to maintain different “views” of your
network. You may want one list set up with a single group to watch
for trouble units, another list set up with logical groupings to easily
perform firmware upgrades, and yet a third list set up with physical
location groupings.
External Internet Access
The console requires access to a pre-established HTTP site for
retrieval of firmware Images and Instructions. If this site is not available,
then FTP (as configured in the Options Dialog Page) is provided as a
backup option. If FTP is disabled or unavailable, then the “Automatic”
aspects of the console will be limited. If firmware Image files and
Instructions have already been installed on the local file system,
then the console can make use of these and work offline.

Warranty
This software is provided as is, with no warranty of any kind. Steelcase
shall not be liable for consequential or incidental damages arising from
any product defect, including without limitation any liability for products
not being available for use or for lost data or software.

How to Configure RoomWizard to reduce security risk /
increase the level of security for PII processed by RoomWizard
The Administrative Console facilitates access to RoomWizard
configuration, logs, and other data, which might include personally
identifiable information (PII). Therefore, it we recommend that the
following minimal steps be taken to reduce security and PII risks.
1. Change the application password for RWAC. (This will restrict access
to the console, which is the best place to begin adding security.)
2. Change the root password on all RoomWizards in your network.
(This will ensure access to the majority of functions and information
on the RoomWizards is restricted only to those who know the
password or have access to the console.)
3. Change the admin password (used to access Admin Pages
on RoomWizard) on all RoomWizards in your network. (This
will ensure only appropriate access can be gained via the
RoomWizard web interface [and front panel].)
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Protected EAP (PEAP)

Starting with version 4.7, RoomWizard supports the use of 802.1x
security option for communication with the attached network.
There are three main security options (PEAP, TLS, and TTLS) with
additional sub-options for each. The user is expected to have
previous knowledge of how to set up these options and settings.
The dialogs for adjusting these settings are shown.
Note that in each of these dialogs, one or more certificate or key may
be requested. If the dialog was brought up from the Configuration
View tab path, then the certificate/key may already exist on the device.
In this event, only the type of dialog will be displayed in the field (e.g.,
.der or .pem) and the user is not required to re-enter a path to a local
certificate. The existing certificate (on the RoomWizard) will continue
to be used. However, the user is free to specify a new certificate by
entering the full local path and filename of the new certificate to place
on RoomWizard.
TLS

Tunneling TLS
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Configure ID Lookup feature
Starting with version 4.7, RoomWizard supports the ability to allow
lookup of a User ID in order to fill in the name data on a “Use Now”
meeting. The dialog for adjusting these settings is shown below.
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Configure sending WD Logs via FTP/SFTP
Starting with version 4.7, RoomWizard supports the ability to upload
logs resulting from a Watchdog Timer event to a user-specified FTP/
SFTP site. The dialog for adjusting these settings is shown below.
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Configure SNMP
Starting with version 4.6 and greatly expanded in 4.7, RoomWizard
supports use of SNMP. SNMP has two main security version options:
v1/v2c and v3. The dialogs for adjusting these settings are shown below.

SNMP v1/v2c

SNMP v3

•• RoomWizard Location is optional information shared between both
security versions and is simply a description of the physical location
of the RoomWizard.

When SNMP v3 option is selected, some additional information is
required to complete the security configuration. The user is expected
to already be familiar with the required information and options.

•• Local RoomWizard Contact is optional information shared between
both security versions and is simply a description of any contact
information the user wishes to associate with this specific
RoomWizard.
•• Manager (Approved IP) List is a list of IPs that represents SNMP
Manager devices (up to a max of five) where an SNMP Application is
potentially run and can query and receive traps from the RoomWizard
SNMP interface. The RoomWizard will limit contact to ONLY the IPs
on this list and neither accept commands from nor send traps to any
other IPs. At least one IP should be present on this list.

•• Authentication Protocol
•• Privacy Protocol
•• Privacy Key
•• L3 Username
•• L3 Password

•• Community String is specific to v1/v2c and represents something
similar to a password that must be presented when issuing
commands to the RoomWizard SNMP interface
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Customize Front Panel Display
Starting with version 4.7, RoomWizard supports the ability to
customize the color, gradient effect, and badging (also known as
a logo) on the front panel. The dialog for adjusting these settings
is shown below.

The fields associated with this dialog are listed below. The checkboxes
labeled “No Change” allow the user to adjust some aspects of the
customization while leaving others unchanged.
Set Background
The setting allows the user to set the background color for the
RoomWizard front panel display. There are several predetermined
colors, and the option to specify a custom color is also provided. Any
selection made will also result in a gradient (fading) background. The
two exceptions are the default Steelcase blue and the flat black
options at the top of the section.
Set Badge
This setting has two components, the selection of the badge (or
logo) itself and the ability to specify a URL that will be navigated to if
the user clicks on the badge while viewing the RoomWizard from its
web interface.
•• Upload Badge File allows the user to specify an image file
(max size 5MB) to be displayed in the upper right corner of the
RoomWizard front panel. For best effect, the image should
have a transparent background.
•• Click URL allows the user to specify a link to navigate to if the
badge image is clicked while viewing the RoomWizard front
panel via the web interface.
View
The view is informational only and gives the user an idea of what the
customized front panel will look like. The Available/Reserved condition
refers to the sizing of the badge: full size when available, reduced size
when RoomWizard is in use.
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Configure Connector Synchronization
Starting with version 4.8, RoomWizard supports the ability to
configure the synchronization of the device with an external
calendaring system by means of a “connector.” The dialog
for adjusting these settings is shown below.

•• Connector URL The RoomWizard must communicate with the
connector via a public URL. This should be entered here.
••Authentication Mode is dependent on the connector.
- Depending on the authentication mode, a username might
be required to access the Connector URL.
•• Poll Interval allows user to suggest a minimum polling interval
that the RoomWizard can use to regulate communications with the
connector to assess changes in status.

•• Room Specific Info entry method The room resources for each
RoomWizard will be unique to that RoomWizard and so must be
entered independently even if all other settings will be the same for
all the RoomWizards being configured. There are two options for
doing this.
The user can choose to manually enter the room ID and password
for each RoomWizard as it is processed and, if choosing this option, the
user will be presented with the following dialog for each RoomWizard:

•• Get time from Sync Server allows user to specify that RoomWizard
will get its understanding of the current time from the same server
used for the connector.
•• Update Room Resources Only In some circumstances, the
credentials for the rooms using a particular connector might need
to be set (as they are unique to each room), while the remaining
connector details do not require changes (as they are public
and the same for all RoomWizards using the connector). In this
case, the user can check this box so that only the room-specific
information will be adjusted.

Alternatively, the user can create a CSV file and will be prompted
to enter its file location as shown here.

The file should have entries in the form RW IP, RW ID, RW PW
where the RoomWizard IP is the first entry, followed by a comma,
followed by the desired RoomWizard Room ID, then a comma, and
finally the RoomWizard Room password, which ends the line. Each
RoomWizard should have its own line in the file. If the RoomWizard is
not found in the given CSV file, then RWAC will fall back to prompting
the user to enter the information manually for that specific RoomWizard.
19

Visit Steelcase.com
facebook.com/Steelcase

twitter.com/Steelcase

youtube.com/SteelcaseTV

7/18 ©2018 Steelcase Inc. All rights reserved. All specifications subject to change without notice.
Trademarks used herein are the property of Steelcase Inc. or of their respective owners.

